PyPI/proxy-py CVE-2021-3116: unknown, EPSS 1.69%
before_upstream_connection in AuthPlugin in http/proxy/auth.py in proxy.py before 2.3.1 accepts incorrect Proxy-Authorization header data because of a boolean confusion (and versus or).
Action: Upgrade proxy-py to 2.3.1 or later.
pip install proxy-py==2.3.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.3.1 | - |
Fixed versions
| 2.3.1 |
Sources
- osv: PYSEC-2021-46
- https://pypi.org/project/proxy.py/2.3.1/#history
- https://cardaci.xyz/advisories/2021/01/10/proxy.py-2.3.0-broken-basic-authentication/
- https://github.com/abhinavsingh/proxy.py/pull/482/commits/9b00093288237f5073c403f2c4f62acfdfa8ed46
- https://github.com/advisories/GHSA-cmc7-mfmr-xqrx
CVE-2021-3116 · published · modified · JSON