PyPI/tensorflow-cpu CVE-2021-29535: unknown, EPSS 0.21%
TensorFlow is an end-to-end open source platform for machine learning. An attacker can cause a heap buffer overflow in `QuantizedMul` by passing in invalid thresholds for the quantization. This is bec
Action: Upgrade tensorflow-cpu to 2.2.0rc0 or later.
pip install tensorflow-cpu==2.2.0rc0pip install tensorflow-cpu==2.3.0rc0pip install tensorflow-cpu==2.3.4pip install tensorflow-cpu==2.4.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.2.0rc0 | - |
| 2.2.0 | 2.3.0rc0 | - |
| 2.3.0 | 2.3.4 | - |
| 2.4.0 | 2.4.3 | - |
Fixed versions
| 2.2.0rc0 | 2.3.0rc0 | 2.3.4 | 2.4.3 |
Sources
- osv: PYSEC-2021-463
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-m3f9-w3p3-p669
- https://github.com/tensorflow/tensorflow/commit/efea03b38fb8d3b81762237dc85e579cc5fc6e87
CVE-2021-29535 · published · modified · JSON