PyPI/tensorflow-cpu CVE-2021-29536: unknown, EPSS 0.21%
TensorFlow is an end-to-end open source platform for machine learning. An attacker can cause a heap buffer overflow in `QuantizedReshape` by passing in invalid thresholds for the quantization. This is
Action: Upgrade tensorflow-cpu to 2.2.0rc0 or later.
pip install tensorflow-cpu==2.2.0rc0pip install tensorflow-cpu==2.3.0rc0pip install tensorflow-cpu==2.3.4pip install tensorflow-cpu==2.4.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.2.0rc0 | - |
| 2.2.0 | 2.3.0rc0 | - |
| 2.3.0 | 2.3.4 | - |
| 2.4.0 | 2.4.3 | - |
Fixed versions
| 2.2.0rc0 | 2.3.0rc0 | 2.3.4 | 2.4.3 |
Sources
- osv: PYSEC-2021-464
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-2gfx-95x2-5v3x
- https://github.com/tensorflow/tensorflow/commit/a324ac84e573fba362a5e53d4e74d5de6729933e
CVE-2021-29536 · published · modified · JSON