PyPI/tensorflow-cpu CVE-2021-29581: unknown, EPSS 0.19%
TensorFlow is an end-to-end open source platform for machine learning. Due to lack of validation in `tf.raw_ops.CTCBeamSearchDecoder`, an attacker can trigger denial of service via segmentation faults
Action: Upgrade tensorflow-cpu to 2.1.4 or later.
pip install tensorflow-cpu==2.1.4pip install tensorflow-cpu==2.2.3pip install tensorflow-cpu==2.3.3pip install tensorflow-cpu==2.4.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.1.4 | - |
| 2.2.0 | 2.2.3 | - |
| 2.3.0 | 2.3.3 | - |
| 2.4.0 | 2.4.2 | - |
Fixed versions
| 2.1.4 | 2.2.3 | 2.3.3 | 2.4.2 |
Sources
- osv: PYSEC-2021-509
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-vq2r-5xvm-3hc3
- https://github.com/tensorflow/tensorflow/commit/b1b323042264740c398140da32e93fb9c2c9f33e
CVE-2021-29581 · published · modified · JSON