PyPI/tensorflow-gpu CVE-2021-29529: unknown, EPSS 0.25%
TensorFlow is an end-to-end open source platform for machine learning. An attacker can trigger a heap buffer overflow in `tf.raw_ops.QuantizedResizeBilinear` by manipulating input values so that float
Action: Upgrade tensorflow-gpu to 2.1.4 or later.
pip install tensorflow-gpu==2.1.4pip install tensorflow-gpu==2.2.3pip install tensorflow-gpu==2.3.3pip install tensorflow-gpu==2.4.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.1.4 | - |
| 2.2.0 | 2.2.3 | - |
| 2.3.0 | 2.3.3 | - |
| 2.4.0 | 2.4.2 | - |
Fixed versions
| 2.1.4 | 2.2.3 | 2.3.3 | 2.4.2 |
Sources
- osv: PYSEC-2021-655
- https://github.com/tensorflow/tensorflow/commit/f851613f8f0fb0c838d160ced13c134f778e3ce7
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-jfp7-4j67-8r3q
CVE-2021-29529 · published · modified · JSON