PyPI/tensorflow-gpu CVE-2021-29566: unknown, EPSS 0.20%
TensorFlow is an end-to-end open source platform for machine learning. An attacker can write outside the bounds of heap allocated arrays by passing invalid arguments to `tf.raw_ops.Dilation2DBackpropI
Action: Upgrade tensorflow-gpu to 2.2.0rc0 or later.
pip install tensorflow-gpu==2.2.0rc0pip install tensorflow-gpu==2.3.0rc0pip install tensorflow-gpu==2.3.4pip install tensorflow-gpu==2.4.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.2.0rc0 | - |
| 2.2.0 | 2.3.0rc0 | - |
| 2.3.0 | 2.3.4 | - |
| 2.4.0 | 2.4.3 | - |
Fixed versions
| 2.2.0rc0 | 2.3.0rc0 | 2.3.4 | 2.4.3 |
Sources
- osv: PYSEC-2021-692
- https://github.com/tensorflow/tensorflow/commit/3f6fe4dfef6f57e768260b48166c27d148f3015f
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-pvrc-hg3f-58r6
CVE-2021-29566 · published · modified · JSON