PyPI/tensorflow-gpu CVE-2021-29613: unknown, EPSS 0.24%
TensorFlow is an end-to-end open source platform for machine learning. Incomplete validation in `tf.raw_ops.CTCLoss` allows an attacker to trigger an OOB read from heap. The fix will be included in Te
Action: Upgrade tensorflow-gpu to 2.1.4 or later.
pip install tensorflow-gpu==2.1.4pip install tensorflow-gpu==2.2.3pip install tensorflow-gpu==2.3.3pip install tensorflow-gpu==2.4.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.1.4 | - |
| 2.2.0 | 2.2.3 | - |
| 2.3.0 | 2.3.3 | - |
| 2.4.0 | 2.4.2 | - |
Fixed versions
| 2.1.4 | 2.2.3 | 2.3.3 | 2.4.2 |
Sources
- osv: PYSEC-2021-739
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-vvg4-vgrv-xfr7
- https://github.com/tensorflow/tensorflow/commit/14607c0707040d775e06b6817325640cb4b5864c
- https://github.com/tensorflow/tensorflow/commit/4504a081af71514bb1828048363e6540f797005b
CVE-2021-29613 · published · modified · JSON