PyPI/tensorflow-gpu CVE-2021-41225: unknown, EPSS 0.20%
TensorFlow is an open source platform for machine learning. In affected versions TensorFlow's Grappler optimizer has a use of unitialized variable. If the `train_nodes` vector (obtained from the saved
Action: Upgrade tensorflow-gpu to 2.4.4 or later.
pip install tensorflow-gpu==2.4.4pip install tensorflow-gpu==2.5.2pip install tensorflow-gpu==2.6.1pip install tensorflow-gpu==2.7.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.4.4 | - |
| 2.5.0 | 2.5.2 | - |
| 2.6.0 | 2.6.1 | - |
| 2.7.0rc0 | 2.7.0 | - |
Fixed versions
| 2.4.4 | 2.5.2 | 2.6.1 | 2.7.0 |
Sources
- osv: PYSEC-2021-832
- https://github.com/tensorflow/tensorflow/commit/68867bf01239d9e1048f98cbad185bf4761bedd3
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-7r94-xv9v-63jw
CVE-2021-41225 · published · modified · JSON