PyPI/tensorflow-gpu CVE-2021-41195: unknown, EPSS 0.21%
TensorFlow is an open source platform for machine learning. In affected versions the implementation of `tf.math.segment_*` operations results in a `CHECK`-fail related abort (and denial of service) if
Action: Upgrade tensorflow-gpu to 2.4.4 or later.
pip install tensorflow-gpu==2.4.4pip install tensorflow-gpu==2.5.2pip install tensorflow-gpu==2.6.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.4.4 | - |
| 2.5.0 | 2.5.2 | - |
| 2.6.0 | 2.6.1 | - |
Fixed versions
| 2.4.4 | 2.5.2 | 2.6.1 |
Sources
- osv: PYSEC-2021-846
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-cq76-mxrc-vchh
- https://github.com/tensorflow/tensorflow/commit/e9c81c1e1a9cd8dd31f4e83676cab61b60658429
- https://github.com/tensorflow/tensorflow/pull/51733
- https://github.com/tensorflow/tensorflow/issues/46888
CVE-2021-41195 · published · modified · JSON