PyPI/numpy CVE-2021-41496: unknown, EPSS 0.40%
Buffer overflow in the array_from_pyobj function of fortranobject.c in NumPy < 1.19, which allows attackers to conduct a Denial of Service attacks by carefully constructing an array with negative valu
Action: Upgrade numpy to 1.19.0 or later.
pip install numpy==1.19.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.19.0 | - |
Fixed versions
| 1.19.0 |
Sources
- osv: PYSEC-2021-857
- https://github.com/numpy/numpy/issues/19000
- https://github.com/advisories/GHSA-f7c7-j99h-c22f
CVE-2021-41496 · published · modified · JSON