PyPI/tensorflow-gpu CVE-2022-21730: unknown, EPSS 0.82%
Tensorflow is an Open Source Machine Learning Framework. The implementation of `FractionalAvgPoolGrad` does not consider cases where the input tensors are invalid allowing an attacker to read from out
Action: Upgrade tensorflow-gpu to 2.5.3 or later.
pip install tensorflow-gpu==2.5.3pip install tensorflow-gpu==2.6.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.5.3 | - |
| 2.6.0 | 2.6.3 | - |
Fixed versions
| 2.5.3 | 2.6.3 |
Sources
- osv: PYSEC-2022-109
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-vjg4-v33c-ggc4
- https://github.com/tensorflow/tensorflow/commit/002408c3696b173863228223d535f9de72a101a9
- https://github.com/tensorflow/tensorflow/blob/5100e359aef5c8021f2e71c7b986420b85ce7b3d/tensorflow/core/kernels/fractional_avg_pool_op.cc#L209-L360
CVE-2022-21730 · published · modified · JSON