PyPI/jupyter-server-proxy CVE-2022-21697: unknown, EPSS 1.10%
Jupyter Server Proxy is a Jupyter notebook server extension to proxy web services. Versions of Jupyter Server Proxy prior to 3.2.1 are vulnerable to Server-Side Request Forgery (SSRF). Any user deploy
Action: Upgrade jupyter-server-proxy to 3.2.1 or later.
pip install jupyter-server-proxy==3.2.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 3.2.1 | - |
Fixed versions
| 3.2.1 |
Sources
- osv: PYSEC-2022-16
- https://github.com/jupyterhub/jupyter-server-proxy/compare/v3.2.0...v3.2.1.patch
- https://github.com/jupyterhub/jupyter-server-proxy/security/advisories/GHSA-gcv9-6737-pjqw
- https://github.com/jupyterhub/jupyter-server-proxy/commit/fd31930bacd12188c448c886e0783529436b99eb
CVE-2022-21697 · published · modified · JSON