PyPI/ansible CVE-2021-3620: unknown, EPSS 0.39%
A flaw was found in Ansible Engine's ansible-connection module, where sensitive information such as the Ansible user credentials is disclosed by default in the traceback error message. The highest thr
Action: Upgrade ansible to 2.9.27 or later.
pip install ansible==2.9.27Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.9.27 | - |
Fixed versions
| 2.9.27 |
Sources
- osv: PYSEC-2022-164
- https://github.com/ansible/ansible/commit/fe28767970c8ec62aabe493c46b53a5de1e5fac0
- https://github.com/ansible/ansible/blob/stable-2.9/changelogs/CHANGELOG-v2.9.rst#security-fixes
- https://bugzilla.redhat.com/show_bug.cgi?id=1975767
- https://github.com/advisories/GHSA-4r65-35qq-ch8j
CVE-2021-3620 · published · modified · JSON