PyPI/waitress CVE-2022-24761: unknown, EPSS 1.78%
Waitress is a Web Server Gateway Interface server for Python 2 and 3. When using Waitress versions 2.1.0 and prior behind a proxy that does not properly validate the incoming HTTP request matches the
Action: Upgrade waitress to 2.1.1 or later.
pip install waitress==2.1.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.1.1 | - |
Fixed versions
| 2.1.1 |
Sources
- osv: PYSEC-2022-169
- https://github.com/Pylons/waitress/commit/9e0b8c801e4d505c2ffc91b891af4ba48af715e0
- https://github.com/Pylons/waitress/security/advisories/GHSA-4f7p-27jc-3c36
- https://github.com/Pylons/waitress/releases/tag/v2.1.1
CVE-2022-24761 · published · modified · JSON