PyPI/mitmproxy CVE-2022-24766: unknown, EPSS 1.63%
mitmproxy is an interactive, SSL/TLS-capable intercepting proxy. In mitmproxy 7.0.4 and below, a malicious client or server is able to perform HTTP request smuggling attacks through mitmproxy. This me
Action: Upgrade mitmproxy to 8.0.0 or later.
pip install mitmproxy==8.0.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 8.0.0 | - |
Fixed versions
| 8.0.0 |
Sources
- osv: PYSEC-2022-170
- https://mitmproxy.org/posts/releases/mitmproxy8/
- https://github.com/mitmproxy/mitmproxy/security/advisories/GHSA-gcx2-gvj7-pxv3
- https://github.com/mitmproxy/mitmproxy/commit/b06fb6d157087d526bd02e7aadbe37c56865c71b
CVE-2022-24766 · published · modified · JSON