PyPI/django CVE-2022-28347: unknown, EPSS 2.94%
A SQL injection issue was discovered in QuerySet.explain() in Django 2.2 before 2.2.28, 3.2 before 3.2.13, and 4.0 before 4.0.4. This occurs by passing a crafted dictionary (with dictionary expansion)
Action: Upgrade django to 2.2.28 or later.
pip install django==4.0.4pip install django==3.2.13pip install django==2.2.28Affected
| introduced | fixed | last affected |
|---|---|---|
| 2.2 | 2.2.28 | - |
| 3.2 | 3.2.13 | - |
| 4.0 | 4.0.4 | - |
Fixed versions
| 4.0.4 | 3.2.13 | 2.2.28 |
Sources
- osv: PYSEC-2022-191
- http://www.openwall.com/lists/oss-security/2022/04/11/1
- https://docs.djangoproject.com/en/4.0/releases/security/
- https://www.djangoproject.com/weblog/2022/apr/11/security-releases/
- https://groups.google.com/forum/#!forum/django-announce
- https://github.com/advisories/GHSA-w24h-v9qh-8gxj
CVE-2022-28347 · published · modified · JSON