PyPI/twisted CVE-2022-24801: unknown, EPSS 2.80%
Twisted is an event-based framework for internet applications, supporting Python 3.6+. Prior to version 22.4.0rc1, the Twisted Web HTTP 1.1 server, located in the `twisted.web.http` module, parsed sev
Action: Upgrade twisted to 22.4.0 or later.
pip install twisted==22.4.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 22.4.0 | - |
Fixed versions
| 22.4.0 |
Sources
- osv: PYSEC-2022-195
- https://github.com/twisted/twisted/commit/592217e951363d60e9cd99c5bbfd23d4615043ac
- https://github.com/twisted/twisted/releases/tag/twisted-22.4.0rc1
- https://github.com/twisted/twisted/security/advisories/GHSA-c2jg-hw38-jrqq
- https://lists.debian.org/debian-lts-announce/2022/05/msg00003.html
CVE-2022-24801 · published · modified · JSON