PyPI/pyspark CVE-2022-31777: unknown, EPSS 1.64%
A stored cross-site scripting (XSS) vulnerability in Apache Spark 3.2.1 and earlier, and 3.3.0, allows remote attackers to execute arbitrary JavaScript in the web browser of a user, by including a mal
Action: Upgrade pyspark to 3.2.2 or later.
pip install pyspark==3.2.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 3.2.2 | - |
Fixed versions
| 3.2.2 |
Sources
- osv: PYSEC-2022-42976
- https://lists.apache.org/thread/60mgbswq2lsmrxykfxpqq13ztkm2ht6q
- https://github.com/advisories/GHSA-43xg-8wmj-cw8h
CVE-2022-31777 · published · modified · JSON