PyPI/tensorflow-cpu CVE-2022-23568: unknown, EPSS 0.81%
Tensorflow is an Open Source Machine Learning Framework. The implementation of `AddManySparseToTensorsMap` is vulnerable to an integer overflow which results in a `CHECK`-fail when building new `Tenso
Action: Upgrade tensorflow-cpu to 2.5.3 or later.
pip install tensorflow-cpu==2.5.3pip install tensorflow-cpu==2.6.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.5.3 | - |
| 2.6.0 | 2.6.3 | - |
Fixed versions
| 2.5.3 | 2.6.3 |
Sources
- osv: PYSEC-2022-77
- https://github.com/tensorflow/tensorflow/blob/5100e359aef5c8021f2e71c7b986420b85ce7b3d/tensorflow/core/kernels/sparse_tensors_map_ops.cc
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-6445-fm66-fvq2
- https://github.com/tensorflow/tensorflow/commit/b51b82fe65ebace4475e3c54eb089c18a4403f1c
- https://github.com/tensorflow/tensorflow/commit/a68f68061e263a88321c104a6c911fe5598050a8
CVE-2022-23568 · published · modified · JSON