PyPI/langchain CVE-2023-36188: unknown, EPSS 1.90%
An issue in langchain v.0.0.64 allows a remote attacker to execute arbitrary code via the PALChain parameter in the Python exec method.
Action: Upgrade langchain to 0.0.247 or later.
pip install langchain==0.0.247Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.0.247 | - |
Fixed versions
| 0.0.247 |
Sources
- osv: PYSEC-2023-109
- https://github.com/langchain-ai/langchain/issues/5872
- https://github.com/langchain-ai/langchain/pull/8425
- https://github.com/advisories/GHSA-57fc-8q82-gfp3
CVE-2023-36188 · published · modified · JSON