PyPI/langchain CVE-2023-36095: critical 9.8, EPSS 1.17%
An issue in Harrison Chase langchain v.0.0.194 allows an attacker to execute arbitrary code via the python exec calls in the PALChain, affected functions include from_math_prompt and from_colored_obje
Action: Upgrade langchain to 0.0.236 or later.
pip install langchain==0.0.236Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.0.236 | - |
Fixed versions
| 0.0.236 |
Sources
- osv: PYSEC-2023-138
- https://github.com/hwchase17/langchain
- http://langchain.com
- https://github.com/langchain-ai/langchain/issues/5872
- https://github.com/advisories/GHSA-gwqq-6vq7-5j86
CVE-2023-36095 · published · modified · JSON