tocsin

PyPI/langchain CVE-2023-38896: critical 9.8, EPSS 1.84%

An issue in Harrison Chase langchain v.0.0.194 and before allows a remote attacker to execute arbitrary code via the from_math_prompt and from_colored_object_prompt functions.

Action: Upgrade langchain to 0.0.195 or later.

pip install langchain==0.0.195

Affected

introducedfixedlast affected
00.0.195-

Fixed versions

0.0.195

Sources

CVE-2023-38896 · published · modified · JSON