PyPI/langchain CVE-2023-39659: critical 9.8, EPSS 1.53%
An issue in langchain langchain-ai v.0.0.232 and before allows a remote attacker to execute arbitrary code via a crafted script to the PythonAstREPLTool._run component.
Action: Upgrade langchain to 0.0.233 or later.
pip install langchain==0.0.233Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.0.233 | - |
Fixed versions
| 0.0.233 |
Sources
- osv: PYSEC-2023-147
- https://github.com/langchain-ai/langchain/issues/7700
- https://github.com/langchain-ai/langchain/pull/5640
- https://github.com/advisories/GHSA-prgp-w7vf-ch62
CVE-2023-39659 · published · modified · JSON