tocsin

PyPI/llama-index CVE-2023-39662: critical 9.8, EPSS 1.49%

An issue in llama_index v.0.7.13 and before allows a remote attacker to execute arbitrary code via the `exec` parameter in PandasQueryEngine function.

Action: Upgrade llama-index to 0.7.14 or later.

pip install llama-index==0.7.14

Affected

introducedfixedlast affected
00.7.14-

Fixed versions

0.7.14

Sources

CVE-2023-39662 · published · modified · JSON