PyPI/jupyter-server CVE-2023-40170: medium 6.1, EPSS 0.62%
jupyter-server is the backend for Jupyter web applications. Improper cross-site credential checks on `/files/` URLs could allow exposure of certain file contents, or accessing files when opening untru
Action: Upgrade jupyter-server to 2.7.2 or later.
pip install jupyter-server==2.7.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.7.2 | - |
Fixed versions
| 2.7.2 |
Sources
- osv: PYSEC-2023-157
- https://github.com/jupyter-server/jupyter_server/security/advisories/GHSA-64x5-55rw-9974
- https://github.com/jupyter-server/jupyter_server/commit/87a4927272819f0b1cae1afa4c8c86ee2da002fd
CVE-2023-40170 · published · modified · JSON