PyPI/langchain CVE-2023-39631: critical 9.8, EPSS 1.60%
An issue in LanChain-ai Langchain v.0.0.245 allows a remote attacker to execute arbitrary code via the evaluate function in the numexpr library.
Action: Upgrade langchain to 0.0.308 or later.
pip install langchain==0.0.308Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.0.308 | - |
Fixed versions
| 0.0.308 |
Sources
- osv: PYSEC-2023-162
- https://github.com/pydata/numexpr/issues/442
- https://github.com/langchain-ai/langchain/issues/8363
- https://github.com/langchain-ai/langchain/pull/11302
CVE-2023-39631 · published · modified · JSON