PyPI/apache-airflow CVE-2023-45348: medium 4.3, EPSS 1.60%
Apache Airflow, versions 2.7.0 and 2.7.1, is affected by a vulnerability that allows an authenticated user to retrieve sensitive configuration information when the "expose_config" option is set to "no
Action: Upgrade apache-airflow to 2.7.2 or later.
pip install apache-airflow==2.7.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 2.7.0 | 2.7.2 | - |
Fixed versions
| 2.7.2 |
Sources
- osv: PYSEC-2023-204
- https://lists.apache.org/thread/sy4l5d6tn58hr8r61r2fkt1f0qock9z9
- https://github.com/apache/airflow/pull/34712
- https://github.com/advisories/GHSA-fpxx-xv4c-gxqp
CVE-2023-45348 · published · modified · JSON