tocsin

PyPI/mechanize CVE-2021-32837: unknown, EPSS 28.87%

mechanize, a library for automatically interacting with HTTP web servers, contains a regular expression that is vulnerable to regular expression denial of service (ReDoS) prior to version 0.4.6. If a

Action: Upgrade mechanize to 0.4.6 or later.

pip install mechanize==0.4.6

Affected

introducedfixedlast affected
00.4.6-

Fixed versions

0.4.6

Sources

CVE-2021-32837 · published · modified · JSON