PyPI/apache-airflow CVE-2023-49920: medium 6.5, EPSS 1.03%
Apache Airflow, version 2.7.0 through 2.7.3, has a vulnerability that allows an attacker to trigger a DAG in a GET request without CSRF validation. As a result, it was possible for a malicious website
Action: Upgrade apache-airflow to 2.8.0b1 or later.
pip install apache-airflow==2.8.0b1Affected
| introduced | fixed | last affected |
|---|---|---|
| 2.7.0 | 2.8.0b1 | - |
Fixed versions
| 2.8.0b1 |
Sources
- osv: PYSEC-2023-266
- https://github.com/apache/airflow/pull/36026
- https://lists.apache.org/thread/mnwd2vcfw3gms6ft6kl951vfbqrxsnjq
- http://www.openwall.com/lists/oss-security/2023/12/21/3
- https://github.com/advisories/GHSA-6m9r-7wrx-xmr6
CVE-2023-49920 · published · modified · JSON