tocsin

PyPI/pyspark CVE-2023-22946: unknown, EPSS 1.11%

In Apache Spark versions prior to 3.4.0, applications using spark-submit can specify a 'proxy-user' to run as, limiting privileges. The application can execute code with the privileges of the submitti

Action: Upgrade pyspark to 3.4.0 or later.

pip install pyspark==3.4.0

Affected

introducedfixedlast affected
03.4.0-

Fixed versions

3.4.0

Sources

CVE-2023-22946 · published · modified · JSON