PyPI/flask CVE-2023-30861: unknown, EPSS 1.25%
Flask is a lightweight WSGI web application framework. When all of the following conditions are met, a response containing data intended for one client may be cached and subsequently sent by the proxy
Action: Upgrade flask to 2.2.5 or later.
pip install flask==2.2.5pip install flask==2.3.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.2.5 | - |
| 2.3.0 | 2.3.2 | - |
Fixed versions
| 2.2.5 | 2.3.2 |
Sources
- osv: PYSEC-2023-62
- https://github.com/pallets/flask/commit/70f906c51ce49c485f1d355703e9cc3386b1cc2b
- https://github.com/pallets/flask/releases/tag/2.3.2
- https://github.com/pallets/flask/releases/tag/2.2.5
- https://github.com/pallets/flask/security/advisories/GHSA-m2qf-hxjv-5gpq
- https://github.com/pallets/flask/commit/afd63b16170b7c047f5758eb910c416511e9c965
CVE-2023-30861 · published · modified · JSON