PyPI/requests CVE-2023-32681: unknown, EPSS 2.97%
Requests is a HTTP library. Since Requests 2.3.0, Requests has been leaking Proxy-Authorization headers to destination servers when redirected to an HTTPS endpoint. This is a product of how we use `re
Action: Upgrade requests to 2.31.0 or later.
pip install requests==2.31.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 2.3.0 | 2.31.0 | - |
Fixed versions
| 2.31.0 |
Sources
- osv: PYSEC-2023-74
- https://github.com/psf/requests/security/advisories/GHSA-j8r2-6x86-q33q
- https://github.com/psf/requests/releases/tag/v2.31.0
- https://github.com/psf/requests/commit/74ea7cf7a6a27a4eeb2ae24e162bcc942a6706d5
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/AW7HNFGYP44RT3DUDQXG2QT3OEV2PJ7Y/
CVE-2023-32681 · published · modified · JSON