PyPI/sqlparse CVE-2023-30608: unknown, EPSS 0.98%
sqlparse is a non-validating SQL parser module for Python. In affected versions the SQL parser contains a regular expression that is vulnerable to ReDoS (Regular Expression Denial of Service). This is
Action: Upgrade sqlparse to 0.4.4 or later.
pip install sqlparse==0.4.4Affected
| introduced | fixed | last affected |
|---|---|---|
| 0.1.15 | 0.4.4 | - |
Fixed versions
| 0.4.4 |
Sources
- osv: PYSEC-2023-87
- https://github.com/andialbrecht/sqlparse/security/advisories/GHSA-rrm6-wvj7-cwh2
- https://owasp.org/www-community/attacks/Regular_expression_Denial_of_Service_-_ReDoS
- https://github.com/andialbrecht/sqlparse/commit/c457abd5f097dd13fb21543381e7cfafe7d31cfb
- https://github.com/andialbrecht/sqlparse/commit/e75e35869473832a1eb67772b1adfee2db11b85a
- https://lists.debian.org/debian-lts-announce/2023/05/msg00017.html
CVE-2023-30608 · published · modified · JSON