PyPI/django CVE-2024-45230: unknown, EPSS 25.77%
An issue was discovered in Django 5.1 before 5.1.1, 5.0 before 5.0.9, and 4.2 before 4.2.16. The urlize() and urlizetrunc() template filters are subject to a potential denial-of-service attack via ver
Action: Upgrade django to 4.2.16 or later.
pip install django==5.1.1pip install django==5.0.9pip install django==4.2.16Affected
| introduced | fixed | last affected |
|---|---|---|
| 4.2 | 4.2.16 | - |
| 5.0 | 5.0.9 | - |
| 5.1 | 5.1.1 | - |
Fixed versions
| 5.1.1 | 5.0.9 | 4.2.16 |
Sources
- osv: PYSEC-2024-102
- https://docs.djangoproject.com/en/dev/releases/security/
- https://groups.google.com/forum/#%21forum/django-announce
- https://www.djangoproject.com/weblog/2024/sep/03/security-releases/
- https://github.com/advisories/GHSA-5hgc-2vfp-mqvc
CVE-2024-45230 · published · modified · JSON