PyPI/vyper CVE-2024-24559: medium 5.3, EPSS 0.26%
Vyper is a Pythonic Smart Contract Language for the EVM. There is an error in the stack management when compiling the `IR` for `sha3_64`. Concretely, the `height` variable is miscalculated. The vulner
Action: Upgrade vyper to 0.4.0b1 or later.
pip install vyper==0.4.0b1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.4.0b1 | - |
Fixed versions
| 0.4.0b1 |
Sources
- osv: PYSEC-2024-147
- https://github.com/vyperlang/vyper/security/advisories/GHSA-6845-xw22-ffxv
- https://github.com/vyperlang/vyper/blob/c150fc49ee9375a930d177044559b83cb95f7963/vyper/ir/compile_ir.py#L585-L586
CVE-2024-24559 · published · modified · JSON