PyPI/vyper CVE-2024-26149: medium 5.3, EPSS 0.54%
Vyper is a pythonic Smart Contract Language for the ethereum virtual machine. If an excessively large value is specified as the starting index for an array in `_abi_decode`, it can cause the read posi
Action: Upgrade vyper to 0.4.0b1 or later.
pip install vyper==0.4.0b1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.4.0b1 | - |
Fixed versions
| 0.4.0b1 |
Sources
- osv: PYSEC-2024-164
- https://github.com/vyperlang/vyper/security/advisories/GHSA-9p8r-4xp4-gw5w
- https://github.com/advisories/GHSA-9p8r-4xp4-gw5w
CVE-2024-26149 · published · modified · JSON