PyPI/zenml CVE-2024-2035: medium 6.5, EPSS 0.63%
An improper authorization vulnerability exists in the zenml-io/zenml repository, specifically within the API PUT /api/v1/users/id endpoint. This vulnerability allows any authenticated user to modify t
Action: Upgrade zenml to 0.56.2 or later.
pip install zenml==0.56.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.56.2 | - |
Fixed versions
| 0.56.2 |
Sources
- osv: PYSEC-2024-169
- https://huntr.com/bounties/1cfc6493-082e-4229-9f2f-496801a6557c
- https://github.com/zenml-io/zenml/commit/b95f083efffa56831cd41d8ed536aeb0b6038fa3
- https://github.com/advisories/GHSA-9x88-4jg8-4vf7
CVE-2024-2035 · published · modified · JSON