PyPI/langflow CVE-2024-37014: critical 9.8, EPSS 63.67%
Langflow through 0.6.19 allows remote code execution if untrusted users are able to reach the "POST /api/v1/custom_component" endpoint and provide a Python script.
Action: Upgrade langflow to 1.0.0a3 or later.
pip install langflow==1.0.0a3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.0.0a3 | - |
Fixed versions
| 1.0.0a3 |
Sources
- osv: PYSEC-2024-177
- https://github.com/langflow-ai/langflow/issues/1973
- https://github.com/advisories/GHSA-qg33-x2c5-6p44
CVE-2024-37014 · published · modified · JSON