PyPI/octoprint CVE-2024-28237: medium 4.8, EPSS 0.44%
OctoPrint provides a web interface for controlling consumer 3D printers. OctoPrint versions up until and including 1.9.3 contain a vulnerability that allows malicious admins to configure or talk a vic
Action: Upgrade octoprint to 1.10.0 or later.
pip install octoprint==1.10.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.10.0 | - |
Fixed versions
| 1.10.0 |
Sources
- osv: PYSEC-2024-179
- https://github.com/OctoPrint/OctoPrint/security/advisories/GHSA-x7mf-wrh9-r76c
- https://github.com/OctoPrint/OctoPrint/commit/779894c1bc6478332d14bc9ed1006df1354eb517
- https://github.com/advisories/GHSA-x7mf-wrh9-r76c
CVE-2024-28237 · published · modified · JSON