PyPI/apache-airflow CVE-2024-41937: medium 6.1, EPSS 1.73%
Apache Airflow, versions before 2.10.0, have a vulnerability that allows the developer of a malicious provider to execute a cross-site scripting attack when clicking on a provider documentation link.
Action: Upgrade apache-airflow to 2.10.0 or later.
pip install apache-airflow==2.10.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.10.0 | - |
Fixed versions
| 2.10.0 |
Sources
- osv: PYSEC-2024-181
- https://github.com/apache/airflow/pull/40933
- https://lists.apache.org/thread/lwlmgg6hqfmkpvw5py4w53hxyl37jl6d
- http://www.openwall.com/lists/oss-security/2024/08/21/3
- https://github.com/advisories/GHSA-w7cp-g8v7-r54m
CVE-2024-41937 · published · modified · JSON