PyPI/jupyterhub CVE-2024-41942: high 7.2, EPSS 0.59%
JupyterHub is software that allows one to create a multi-user server for Jupyter notebooks. Prior to versions 4.1.6 and 5.1.0, if a user is granted the `admin:users` scope, they may escalate their own
Action: Upgrade jupyterhub to 4.1.6 or later.
pip install jupyterhub==4.1.6Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 4.1.6 | - |
Fixed versions
| 4.1.6 |
Sources
- osv: PYSEC-2024-200
- https://github.com/jupyterhub/jupyterhub/security/advisories/GHSA-9x4q-3gxw-849f
- https://github.com/jupyterhub/jupyterhub/commit/99e2720b0fc626cbeeca3c6337f917fdacfaa428
- https://github.com/jupyterhub/jupyterhub/commit/ff2db557a85b6980f90c3158634bf924063ab8ba
CVE-2024-41942 · published · modified · JSON