tocsin

PyPI/octoprint CVE-2024-49377: medium 6.1, EPSS 0.29%

OctoPrint provides a web interface for controlling consumer 3D printers. OctoPrint versions up until and including 1.10.2 contain reflected XSS vulnerabilities in the login dialog and the standalone a

Action: Upgrade octoprint to 1.10.3 or later.

pip install octoprint==1.10.3

Affected

introducedfixedlast affected
01.10.3-

Fixed versions

1.10.3

Sources

CVE-2024-49377 · published · modified · JSON