PyPI/vyper CVE-2024-32649: medium 5.3, EPSS 0.46%
Vyper is a pythonic Smart Contract Language for the Ethereum virtual machine. In versions 0.3.10 and prior, using the `sqrt` builtin can result in double eval vulnerability when the argument has side-
Action: Upgrade vyper to 0.4.0 or later.
pip install vyper==0.4.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.4.0 | - |
Fixed versions
| 0.4.0 |
Sources
- osv: PYSEC-2024-209
- https://github.com/vyperlang/vyper/security/advisories/GHSA-5jrj-52x8-m64h
- https://github.com/advisories/GHSA-5jrj-52x8-m64h
CVE-2024-32649 · published · modified · JSON