tocsin

PyPI/vyper CVE-2024-32481: medium 5.3, EPSS 0.80%

Vyper is a pythonic Smart Contract Language for the Ethereum virtual machine. Starting in version 0.3.8 and prior to version 0.4.0b1, when looping over a `range` of the form `range(start, start + N)`,

Action: Upgrade vyper to 0.4.0b1 or later.

pip install vyper==0.4.0b1

Affected

introducedfixedlast affected
0.3.80.4.0b1-

Fixed versions

0.4.0b1

Sources

CVE-2024-32481 · published · modified · JSON