PyPI/pycti CVE-2024-37155: high 8.2, EPSS 0.46%
OpenCTI is an open source platform allowing organizations to manage their cyber threat intelligence knowledge and observables. Prior to version 6.1.9, the regex validation used to prevent Introspectio
Action: Upgrade pycti to 6.1.9 or later.
pip install pycti==6.1.9Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 6.1.9 | - |
Fixed versions
| 6.1.9 |
Sources
- osv: PYSEC-2024-313
- https://github.com/OpenCTI-Platform/opencti/blob/6343b82b0b0a5d3ded3b30d08ce282328a556268/opencti-platform/opencti-graphql/src/graphql/graphql.js#L83-L94
- https://github.com/OpenCTI-Platform/opencti/security/advisories/GHSA-4mvw-j8r9-xcgc
- https://github.com/OpenCTI-Platform/opencti/commit/f87d96918c63b0c3d3ebfbea6c789d48e2f56ad5
CVE-2024-37155 · published · modified · JSON