tocsin

PyPI/llama-index CVE-2024-4181: high 8.8, EPSS 2.14%

A command injection vulnerability exists in the RunGptLLM class of the llama_index library, version 0.9.47, used by the RunGpt framework from JinaAI to connect to Language Learning Models (LLMs). The

Action: Upgrade llama-index to 0.10.13 or later.

pip install llama-index==0.10.13

Affected

introducedfixedlast affected
0.9.470.10.13-

Fixed versions

0.10.13

Sources

CVE-2024-4181 · published · modified · JSON