PyPI/dash CVE-2024-21485: medium 5.4, EPSS 1.49%
Versions of the package dash-core-components before 2.13.0; all versions of the package dash-core-components; versions of the package dash before 2.15.0; all versions of the package dash-html-componen
Action: Upgrade dash to 2.13.0 or later.
pip install dash==2.13.0pip install dash==2.15.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.13.0 | - |
| 2.14.0 | 2.15.0 | - |
Fixed versions
| 2.13.0 | 2.15.0 |
Sources
- osv: PYSEC-2024-35
- https://security.snyk.io/vuln/SNYK-JS-DASHCORECOMPONENTS-6183084
- https://security.snyk.io/vuln/SNYK-PYTHON-DASHCORECOMPONENTS-6226334
- https://security.snyk.io/vuln/SNYK-PYTHON-DASH-6226335
- https://security.snyk.io/vuln/SNYK-PYTHON-DASHHTMLCOMPONENTS-6226336
- https://security.snyk.io/vuln/SNYK-JS-DASHHTMLCOMPONENTS-6226337
- https://github.com/plotly/dash/issues/2729
- https://github.com/plotly/dash/pull/2732
- https://github.com/plotly/dash/releases/tag/v2.15.0
- https://github.com/plotly/dash/commit/9920073c9a8619ae8f90fcec1924f2f3a4332a8c
- https://github.com/advisories/GHSA-547x-748v-vp6p
CVE-2024-21485 · published · modified · JSON