tocsin

PyPI/django CVE-2024-39614: unknown, EPSS 28.64%

An issue was discovered in Django 5.0 before 5.0.7 and 4.2 before 4.2.14. get_supported_language_variant() was subject to a potential denial-of-service attack when used with very long strings containi

Action: Upgrade django to 4.2.14 or later.

pip install django==5.0.7
pip install django==4.2.14

Affected

introducedfixedlast affected
4.24.2.14-
5.05.0.7-

Fixed versions

5.0.74.2.14

Sources

CVE-2024-39614 · published · modified · JSON