PyPI/mindsdb CVE-2024-45848: high 8.8, EPSS 0.85%
An arbitrary code execution vulnerability exists in versions 23.12.4.0 up to 24.7.4.1 of the MindsDB platform, when the ChromaDB integration is installed on the server. If a specially crafted ‘INSERT’
Action: Upgrade mindsdb to 24.7.4.1 or later.
pip install mindsdb==24.7.4.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 23.12.4.0 | 24.7.4.1 | - |
Fixed versions
| 24.7.4.1 |
Sources
- osv: PYSEC-2024-78
- https://hiddenlayer.com/sai-security-advisory/2024-09-mindsdb/
- https://github.com/advisories/GHSA-9gq6-6936-885w
CVE-2024-45848 · published · modified · JSON