PyPI/django CVE-2024-56374: high 7.5, EPSS 1.28%
An issue was discovered in Django 5.1 before 5.1.5, 5.0 before 5.0.11, and 4.2 before 4.2.18. Lack of upper-bound limit enforcement in strings passed when performing IPv6 validation could lead to a po
Action: Upgrade django to 4.2.18 or later.
pip install django==5.1.5pip install django==5.0.11pip install django==4.2.18Affected
| introduced | fixed | last affected |
|---|---|---|
| 4.2 | 4.2.18 | - |
| 5.0 | 5.0.11 | - |
| 5.1 | 5.1.5 | - |
Fixed versions
| 5.1.5 | 5.0.11 | 4.2.18 |
Sources
- osv: PYSEC-2025-1
- nvd: CVE-2024-56374
- https://www.djangoproject.com/weblog/2025/jan/14/security-releases/
- https://docs.djangoproject.com/en/dev/releases/security/
- https://groups.google.com/g/django-announce
- http://www.openwall.com/lists/oss-security/2025/01/14/2
- https://github.com/advisories/GHSA-qcgg-j2x8-h9g8
CVE-2024-56374 · published · modified · JSON